Axis are offset when creating pick and place application

I am creating a simple application where I pick a clip from a holder, as you can see in the first picture. However, when I run the program, the pick point are centered in the robot axis, as if camera is detecting it right under the robot. Please watch a video, where I run Mech Vision and Mech Viz separately. I don’t know what is the issue, since I have another 2 application that are working fine, but third one pick point is very off. Thank you.
Mech Software suite 1.7.4
UR Robot 5E
Eye in Hand setup

From your video, it looks like this may be caused by not using the correct external calibration file. Please check your calibration file. You can use the same calibration result with the first two projects. This file is save in project folder/Calibration/[Camera Serial Number]-EyeInHand-[date]. Take the image below as an example.


I also recommend that you check the “reload file” option in the capture image from camera step. This will prevent the file from not loading successfully in the software.