Halcon 20.11.4.0 - ContinuousCaptureSoftwareTrigger - Profiler LNX - Timeout Error

We are using Profiler LNX8300.
We have tested using Mech-Eye Viewer(2.3.0 SDK Version) and it is working fine.
We will be using halcon 20 version to acquire image.
We are using the halcon standard sample code given by Mech-Mind and we are getting timeout error.

attached are the screenshot.
let me know how we can able to resolve this problem.

Hello, this may be an error caused by the network problem that the LNX8300 camera did not receive complete data within the specified time after the collection was started.

Is there an error every time it runs?
Which routine are you using?

Yes, the Error occurs almost everytime. but if we try running the with some changes, it will run 1 time and then the error shows up again.

We are using the sample code which is provided by MechMind without any changes in the code, i.e., continuous-software-trigger.hdev
Besides we have increased the ‘grab_timeout’ to 30sec and ‘GevStream’ to 5000 value, but the problem remains same.
MechEyeViewer is working fine without any error.
Any other way to troubleshoot or debug.

Could you please tell me what changed after you can run once? Is the cable on your computer directly connected to the device?
It is suspected that the problem is caused by network instability.

Change:
(1) scan-line-count: default(1600); Changed to our application 4096
(2) grab_timeout: changed to 30000
(3) GevStreamMaxPacketGaps: changed to 5000
(4) AcqusitionMaxSpped(Hz): default(2000); Changed to our application 900

With the above settings we could able to get the image once in a while.
We have connected the camera to the PC using a Gigabit Ethernet Switch.
We will check the network stability once again and will update the status.

Mech-Eye Viewer 2.3.0
Halcon 20

We have Connected the cameras as per the user manual


We have disabled the firewall settings in PC and enabled the JumboFrames in the Ethernet Controller in PC

We have created the Userset in the Camera and Loaded the “UserSet2” for our project requirement

Type of Image Acquisition: SoftwareTrigger-Continuous

We have tested in Mech-Eye Viewer Application with UserSet2 and there are no issues found.
Please find the attached video for the same.
Also attached the UserSet Config File.

We have tested in Halcon HDev application with UserSet2 and there are some issues.
We have modified the standard halcon code so that no error will occur instead warning occurs. Please find the attached video and the hdev code for the same

Following are observations:
(1) Below are the code Changes: With the below changes the code will run, otherwise the application will stop at ‘grab_data_async’ with timeout error. Screenshot attached.
(a) Image Height from 4096 to 200
(b) Increased ‘GevStreamMaxPacketGaps’
(c) Increased ‘GevStreamMaxBlockDuration’ values
(d) Continuous Capture for 10 images

(2) Since we have enabled the “set_system(‘do_low_error’, ‘true’)”, so we are getting warning message otherwise the warning message dialog will not occur as shown in the video.

(3) The Image is getting corrupted as we can see the image (some black horizontal lines) - data would be missing.

(4) The ‘GevStreamResendPacketCount’ value is monitered for every image. This values is increasing, it means we are losing the packet

What is required for us:
(1) We need the Image Height to 4096 without any problems
(2) We should get ‘GevStreamResendPacketCount’ as 0 inorder to avoid the image corruption.

18_LCA00238A201YD90_parameter_group.json (16.3 KB)
HalconAcquisition.wmv (4.4 MB)
MechEyeViewer.wmv (1.5 MB)
perform_continuous_data_acquisition_software_triggered3.hdev (10.2 KB)

Thank you for the information. The normal operation of the Mech-Eye Viewer indicates that there is no problem with the camera, Halcon will be more demanding on the network, and the most likely cause of this problem is data loss during data transmission.

You can try connecting the camera controller directly to the computer without using the switch, check that the ports on both ends of the network cable are secure, or try upgrading the network card and replacing the network port on the computer. If it’s convenient, you can try another computer test.