Dependency error from Mech-Eye SDK's Python sample

As long as the Mech-Eye SDK version matches the Python sample version, users can use it normally. To ensure smooth operation, the following recommendations can be followed:

  1. It is recommended for customers to use the latest versions of Mech-Eye SDK and Python samples. If an older version of the Python sample is used, when installing Python libraries, it is necessary to specify the version of the MechEyeAPI library (for example: pip install MechEyeAPI==old_version) to use third-party libraries compatible with the old version of Mech-Eye SDK.

  2. If using the latest version of Python samples, a new version of Mech-Eye SDK is required. This is because the new version of Mech-Eye SDK may introduce new features or changes that may not exist in the old SDK, potentially causing errors in the new version of Python samples on the old version of Mech-Eye SDK. Therefore, to avoid issues, it is recommended to use the latest version of Mech-Eye SDK.

In summary, to ensure smooth usage, make sure that the Mech-Eye SDK version matches the Python sample version. This helps to avoid unnecessary compatibility issues and ensures that you can smoothly use all features.